[Ewrt-devel] RE: Mea culpa (was: building from sources)

Charles Hood
Wed Jun 23 16:56:12 PDT 2004


I re-downloaded /ewrt/src/router/splish/src/config.h from CVS to replace my
clobbered one.  I ran your patch against the Makefile to ensure that it
doesn't get re-clobbered.  (Near as I can tell it only comments out a line?)

I was able to run "make" to build the source, with no errors.  A code.bin
file was produced in the image directory as promised.  I was able to flash
my WRT54G with this firmware successfully.  I was able to access the
administration interface.

The path problem for NoCat does indeed appear to be fixed.  However, I am
still having other problems.  These problems were probably there previously
also, I just didn't have time to discover them.

With NoCat turned out, the splash page is only presented to clients on the
LAN interfaces, and not to wireless clients.  I believe someone else
reported this same behavior to the list.  I can click the accept button to
get through to the web interface for the WRT54G, but that's about it.  I am
not getting redirected to the web page I specified for NoCat, nor does the
router appear to work at all.  I can get it to "connect" to my DSL using
PPPoE, but I cannot get the box to actually route any wireless traffic out
to the Internet.  The box also appears to be running very slowly, as if
something is running no quite right.

I'm sorry if this is a big vague.  Any suggestion for troubleshooting?
Should I check out all of the source from CVS instead of using the tarball
plus patches?

Thanks in advance,

-----Original Message-----
From: Irving Popovetsky [mailto:irving at prostructure.com] 
Sent: Tuesday, June 22, 2004 6:50 PM
To: Charles Hood
Cc: omar touhami; Jason; Ewrt-devel
Subject: Mea culpa (was: building from sources)

Okay guys, this was my screwup.  It was /yet another/ timestamp issue
that was screwing things up for you but worked fine in my build

The simple patch I attached should clear things up for you.  I'll commit
something similar shortly if that is the case.


On Tue, 2004-06-22 at 09:45, Irving Popovetsky wrote:
> Hi Charles, you're not the first to have this problem. 
> I think I have this figured out.  In src/router/splish/src/config.h,    
> NC_CONF_PATH should be set to "/etc".  What do you have?
> Update to the latest CVS sources and you should be fine.   If you're
> still having trouble, check this file:
> -Irving
> On Mon, 2004-06-21 at 22:55, Charles Hood wrote:
> > I downloaded the source, modified splash.html, and then built my own
> > code.bin fireware file.  
> > 
> > My firmware loaded fine, but NoCat wasn't working.  Looking at
> > services.out showed a weird error message about /tmp/splish/etc.(some
> > other stuff)
> > 
> >  
> > 
> > There is no /tmp/splish directory... so I looked at the configure
> > scripts on my build machine.
> > 
> > Sure enough, it appears to be setup to build with the /tmp/splish
> > prefix, but I believe this should be /tmp.  (without the /splish)
> > 
> >  
> > 
> > Can anyone confirm this?  What is the proper method to correct this
> > problem?
> > 
> > I now fear there could be other path related problems, I saw other
> > hardcode references to a particular user's /home directory, for
> > example.
> > 
> >  
> > 
> > Please advise.
> > 
> > 
> > Thanks,
> > Charles
> > 
> >  
> > 
> > 
> > 
> > ______________________________________________________________________
> > _______________________________________________
> > Ewrt-devel mailing list
> > Ewrt-devel at portless.net
> > http://strongbad.prostructure.com/mailman/listinfo/ewrt-devel
-Irving Popovetsky
ProStructure Consulting             http://www.prostructure.com
Network and Security Consulting           phone: (503) 288-1566
               "Crafting Connectivity that Matters"

More information about the Ewrt-devel mailing list